Click or drag to resize

CurveProjectToBrep Method (Curve, IEnumerableBrep, Vector3d, Double, Int32)

Projects a Curve onto a collection of Breps along a given direction.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static Curve[] ProjectToBrep(
	Curve curve,
	IEnumerable<Brep> breps,
	Vector3d direction,
	double tolerance,
	out int[] brepIndices
)

Parameters

curve
Type: Rhino.GeometryCurve
Curve to project.
breps
Type: System.Collections.GenericIEnumerableBrep
Breps to project onto.
direction
Type: Rhino.GeometryVector3d
Direction of projection.
tolerance
Type: SystemDouble
Tolerance to use for projection.
brepIndices
Type: SystemInt32
(out) Integers that identify for each resulting curve which Brep it was projected onto.

Return Value

Type: Curve
An array of projected curves or null if the projection set is empty.
See Also