Click or drag to resize

BrepIsValidTopology Method

Tests the brep to see if its topology information is valid.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool IsValidTopology(
	out string log
)

Parameters

log
Type: SystemString
If the brep topology is not valid, then a brief English description of the problem is appended to the log. The information appended to log is suitable for low-level debugging purposes by programmers and is not intended to be useful as a high level user interface tool.

Return Value

Type: Boolean
true if the topology is valid; false otherwise.
See Also