Click or drag to resize

BrepIsValidGeometry Method

Expert user function that tests the brep to see if its geometry information is valid. The value of brep.IsValidTopology() must be true before brep.IsValidGeometry() can be safely called.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool IsValidGeometry(
	out string log
)

Parameters

log
Type: SystemString
If the brep geometry is not valid, then a brief description of the problem in English is assigned to this out parameter. The information is suitable for low-level debugging purposes by programmers and is not intended to be useful as a high level user interface tool. Otherwise, Empty.

Return Value

Type: Boolean
A value that indicates whether the geometry is valid.
See Also