Click or drag to resize

BrepFindCoincidentBrepComponents Method

Find the indices of all brep faces, edges and vertices that are within tolerance of a test-point.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.2
Syntax
public void FindCoincidentBrepComponents(
	Point3d point,
	double tolerance,
	out int[] faces,
	out int[] edges,
	out int[] vertices
)

Parameters

point
Type: Rhino.GeometryPoint3d
Test point.
tolerance
Type: SystemDouble
Coincidence tolerance.
faces
Type: SystemInt32
Array of BrepFace indices.
edges
Type: SystemInt32
Array of BrepEdge indices.
vertices
Type: SystemInt32
Array of BrepVertex indices.
See Also