Click or drag to resize

BrepCopyTrimCurves Method

Copy all trims from a Brep face onto a surface.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static Brep CopyTrimCurves(
	BrepFace trimSource,
	Surface surfaceSource,
	double tolerance
)

Parameters

trimSource
Type: Rhino.GeometryBrepFace
Brep face which defines the trimming curves.
surfaceSource
Type: Rhino.GeometrySurface
The surface to trim.
tolerance
Type: SystemDouble
Tolerance to use for rebuilding 3D trim curves.

Return Value

Type: Brep
A brep with the shape of surfaceSource and the trims of trimSource or null on failure.
See Also