Adds a 3D surface used by BrepFace.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public int AddSurface(
Surface surface
)
Public Function AddSurface (
surface As Surface
) As Integer
Parameters
- surface
- Type: Rhino.GeometrySurface
A copy of the surface is added to this brep.
Return Value
Type:
Int32
Index that should be used to reference the geometry.
-1 is returned if the input is not acceptable.
See Also