Click or drag to resize

BrepSetTolerancesBoxesAndFlags Method (Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

Set tolerances and flags in a Brep.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public void SetTolerancesBoxesAndFlags(
	bool bLazy,
	bool bSetVertexTolerances,
	bool bSetEdgeTolerances,
	bool bSetTrimTolerances,
	bool bSetTrimIsoFlags,
	bool bSetTrimTypeFlags,
	bool bSetLoopTypeFlags,
	bool bSetTrimBoxes
)

Parameters

bLazy
Type: SystemBoolean
If true, only flags and tolerances that are not set will be calculated.
bSetVertexTolerances
Type: SystemBoolean
Set true to compute BrepVertex tolerances.
bSetEdgeTolerances
Type: SystemBoolean
Set true to compute BrepEdge tolerances.
bSetTrimTolerances
Type: SystemBoolean
Set true to compute BrepTrim tolerances.
bSetTrimIsoFlags
Type: SystemBoolean
Set true to compute BrepTrim.IsoStatus values.
bSetTrimTypeFlags
Type: SystemBoolean
Set true to compute BrepTrim.TrimType values.
bSetLoopTypeFlags
Type: SystemBoolean
Set true to compute BrepLoop.BrepLoopType values.
bSetTrimBoxes
Type: SystemBoolean
Set true to compute BrepTrim bounding boxes.
See Also