Click or drag to resize

Cone Structure

Represents the center plane, radius and height values in a right circular cone.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Cone : IEpsilonComparable<Cone>

The Cone type exposes the following members.

Constructors
  NameDescription
Public methodCone
Initializes a new cone with a specified base plane, height and radius.
Top
Properties
  NameDescription
Public propertyApexPoint
Point at tip of the cone.
Public propertyAxis
Unit vector axis of cone.
Public propertyBasePoint
Center of base circle.
Public propertyHeight
Gets or sets the height of the circular right cone.
Public propertyIsValid
true if plane is valid, height is not zero and radius is not zero.
Public propertyPlane
Gets or sets the base plane of the cone. The apex of the cone is at the plane's origin.
Public propertyRadius
Gets or sets the radius of the cone.
Public propertyStatic memberUnset
Gets an invalid Cone.
Top
Methods
  NameDescription
Public methodAngleInDegrees
Computes the angle (in degrees) between the axis and the side of the cone. The angle and the height have the same sign.
Public methodAngleInRadians
Computes the angle (in radians) between the axis and the side of the cone. The angle and the height have the same sign.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodToBrep
Gets a Brep representation of the cone with a single face for the cone, an edge along the cone seam, and vertices at the base and apex ends of this seam edge. The optional cap is a single face with one circular edge starting and ending at the base vertex.
Public methodToNurbsSurface
Constructs a Nurbs surface representation of this Cone. This is synonymous with calling NurbsSurface.CreateFromCone().
Public methodToRevSurface
Constructs a RevSurface representation of this Cone. This is synonymous with calling RevSurface.CreateFromCone().
Top
See Also