Click or drag to resize

Cone Methods

The Cone type exposes the following members.

Methods
  NameDescription
Public methodAngleInDegrees
Computes the angle (in degrees) between the axis and the side of the cone. The angle and the height have the same sign.
Public methodAngleInRadians
Computes the angle (in radians) between the axis and the side of the cone. The angle and the height have the same sign.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodToBrep
Gets a Brep representation of the cone with a single face for the cone, an edge along the cone seam, and vertices at the base and apex ends of this seam edge. The optional cap is a single face with one circular edge starting and ending at the base vertex.
Public methodToNurbsSurface
Constructs a Nurbs surface representation of this Cone. This is synonymous with calling NurbsSurface.CreateFromCone().
Public methodToRevSurface
Constructs a RevSurface representation of this Cone. This is synonymous with calling RevSurface.CreateFromCone().
Top
See Also