HermiteSurface Class |
Namespace: Rhino.Geometry
The HermiteSurface type exposes the following members.
Name | Description | |
---|---|---|
![]() | HermiteSurface |
Initializes a new HermiteSurface instance.
|
![]() | HermiteSurface(Int32, Int32) |
Initializes a new HermiteSurface instance.
|
Name | Description | |
---|---|---|
![]() | IsValid |
Returns true if the all of values in all of the internal data structures contain valid values, false otherwise.
|
![]() | UCount |
Gets the number of parameters in the "u" direction.
|
![]() | VCount |
Gets the number of parameters in the "v" direction.
|
Name | Description | |
---|---|---|
![]() | Dispose |
Actively reclaims unmanaged resources that this instance uses.
|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | PointAt |
Gets the interpolation point at the u,v parameter location.
|
![]() | SetPointAt |
Sets the interpolation point at the u,v parameter location.
|
![]() | SetTwistAt |
Set the twist direction (mixed second partial derivative) to interpolate at the u,v parameter location.
|
![]() | SetUParameterAt |
Sets the "u" parameter at an index. These parameters are strictly increasing.
|
![]() | SetUTangentAt |
Set the "u" tangent direction (actually first derivative) to interpolate at the u,v parameter location.
|
![]() | SetVParameterAt |
Sets the "v" parameter at an index. These parameters are strictly increasing.
|
![]() | SetVTangentAt |
Set the "v" tangent direction (actually first derivative) to interpolate at the u,v parameter location.
|
![]() | ToNurbsSurface |
Constructs a NURBS surface satisfying the Hermite interpolation conditions.
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |
![]() | TwistAt |
Get the twist direction (mixed second partial derivative) to interpolate at the u,v parameter location.
|
![]() | UParameterAt |
Gets the "u" parameter at an index. These parameters are strictly increasing.
|
![]() | UTangentAt |
Get the "u" tangent direction (actually first derivative) to interpolate at the u,v parameter location.
|
![]() | VParameterAt |
Gets the "v" parameter at an index. These parameters are strictly increasing.
|
![]() | VTangentAt |
Get the "v" tangent direction (actually first derivative) to interpolate at the u,v parameter location.
|