Click or drag to resize

HermiteSurface Methods

The HermiteSurface type exposes the following members.

Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodPointAt
Gets the interpolation point at the u,v parameter location.
Public methodSetPointAt
Sets the interpolation point at the u,v parameter location.
Public methodSetTwistAt
Set the twist direction (mixed second partial derivative) to interpolate at the u,v parameter location.
Public methodSetUParameterAt
Sets the "u" parameter at an index. These parameters are strictly increasing.
Public methodSetUTangentAt
Set the "u" tangent direction (actually first derivative) to interpolate at the u,v parameter location.
Public methodSetVParameterAt
Sets the "v" parameter at an index. These parameters are strictly increasing.
Public methodSetVTangentAt
Set the "v" tangent direction (actually first derivative) to interpolate at the u,v parameter location.
Public methodToNurbsSurface
Constructs a NURBS surface satisfying the Hermite interpolation conditions.
Public methodTwistAt
Get the twist direction (mixed second partial derivative) to interpolate at the u,v parameter location.
Public methodUParameterAt
Gets the "u" parameter at an index. These parameters are strictly increasing.
Public methodUTangentAt
Get the "u" tangent direction (actually first derivative) to interpolate at the u,v parameter location.
Public methodVParameterAt
Gets the "v" parameter at an index. These parameters are strictly increasing.
Public methodVTangentAt
Get the "v" tangent direction (actually first derivative) to interpolate at the u,v parameter location.
Top
See Also