Click or drag to resize

RibbonOffsetParameters Class

Advanced parameters for RibbonOffset Parameters mimic the RibbonOffset Command.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryRibbonOffsetParameters

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RibbonOffsetParameters

The RibbonOffsetParameters type exposes the following members.

Constructors
  NameDescription
Public methodRibbonOffsetParameters
Initializes a new instance of the RibbonOffsetParameters class
Top
Properties
  NameDescription
Public propertyAlignCrossSections
When false: cross section slashes between input and output curve are located at the ends of ruled spans. When true: cross section slashes between input and output curve are located at the mid points of ruled spans and blends.
Public propertyBlendRadius
Positive, typically the same as distance. When the offset results in a self-intersection that gets trimmed off at a kink, the kink will be blended out using this radius.
Public propertyOffsetDistance
Offset curve distance from input curve.
Public propertyOffsetLocation
Inside or Outside point location
Public propertyOffsetPlaneVector3d
A vector that indicates the normal of the plane in which the offset will occur. This vector is typically similar to a logical extrude direction for the closed input curve.
Public propertyOffsetTolerance
Used to determine self-intersections of offset curve, not offset error.
Public propertyRebuildPointCount
Rebuild offset curve with defined number of control points 0 for disabled
Public propertyRefitTolerance
Refit the offset curve to a specified tolerance 0 for disabled
Public propertyRibbonSurfaceGenerationMethod
0 - no surfaces will be created, curves only 1 - Simple Sweep 2 2 - Sweep 2 mixed with NetworkSrf corners
Top
Methods
  NameDescription
Top
See Also