Click or drag to resize

Silhouette Class

Information about silhouette curves that are generated from geometry (surfaces, brep faces, meshes)
Inheritance Hierarchy
SystemObject
  Rhino.GeometrySilhouette

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Silhouette

The Silhouette type exposes the following members.

Properties
  NameDescription
Public propertyCurve
3D curve representing the shape of the silhouette.
Public propertyGeometryComponentIndex
Gets the component index corresponding with this silhouette curve. This field is only set when the entire silhouette curve is part of some geometry component.
Public propertySilhouetteType
Gets the type of this silhouette curve.
Top
Methods
  NameDescription
Public methodStatic memberCompute(GeometryBase, SilhouetteType, ViewportInfo, Double, Double)
Compute silhouettes of a shape for a specified projection.
Public methodStatic memberCompute(GeometryBase, SilhouetteType, Point3d, Double, Double)
Compute silhouettes of a shape for a perspective projection.
Public methodStatic memberCompute(GeometryBase, SilhouetteType, Vector3d, Double, Double)
Compute silhouettes of a shape for a parallel projection.
Public methodStatic memberCompute(GeometryBase, SilhouetteType, ViewportInfo, Double, Double, IEnumerablePlane, CancellationToken)
Compute silhouettes of a shape for a specified projection.
Public methodStatic memberCompute(GeometryBase, SilhouetteType, Point3d, Double, Double, IEnumerablePlane, CancellationToken)
Compute silhouettes of a shape for a perspective projection.
Public methodStatic memberCompute(GeometryBase, SilhouetteType, Vector3d, Double, Double, IEnumerablePlane, CancellationToken)
Compute silhouettes of a shape for a parallel projection.
Public methodStatic memberComputeDraftCurve(GeometryBase, Double, Vector3d, Double, Double)
Computes draft curve silhouettes of a shape.
Public methodStatic memberComputeDraftCurve(GeometryBase, Double, Vector3d, Double, Double, CancellationToken)
Computes draft curve silhouettes of a shape.
Top
See Also