Silhouette Methods |
The Silhouette type exposes the following members.
Name | Description | |
---|---|---|
![]() ![]() | Compute(GeometryBase, SilhouetteType, ViewportInfo, Double, Double) |
Compute silhouettes of a shape for a specified projection.
|
![]() ![]() | Compute(GeometryBase, SilhouetteType, Point3d, Double, Double) |
Compute silhouettes of a shape for a perspective projection.
|
![]() ![]() | Compute(GeometryBase, SilhouetteType, Vector3d, Double, Double) |
Compute silhouettes of a shape for a parallel projection.
|
![]() ![]() | Compute(GeometryBase, SilhouetteType, ViewportInfo, Double, Double, IEnumerablePlane, CancellationToken) |
Compute silhouettes of a shape for a specified projection.
|
![]() ![]() | Compute(GeometryBase, SilhouetteType, Point3d, Double, Double, IEnumerablePlane, CancellationToken) |
Compute silhouettes of a shape for a perspective projection.
|
![]() ![]() | Compute(GeometryBase, SilhouetteType, Vector3d, Double, Double, IEnumerablePlane, CancellationToken) |
Compute silhouettes of a shape for a parallel projection.
|
![]() ![]() | ComputeDraftCurve(GeometryBase, Double, Vector3d, Double, Double) |
Computes draft curve silhouettes of a shape.
|
![]() ![]() | ComputeDraftCurve(GeometryBase, Double, Vector3d, Double, Double, CancellationToken) |
Computes draft curve silhouettes of a shape.
|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |