Click or drag to resize

HiddenLineDrawingPoint Class

Points generated from source objects which correspond to point and point cloud source objects.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryHiddenLineDrawingPoint

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class HiddenLineDrawingPoint

The HiddenLineDrawingPoint type exposes the following members.

Properties
  NameDescription
Public propertyClippingPlaneIndex
Index into HiddenLineDrawing.ClippingPlanes when SilhouetteType == SilhouetteType.SectionCut.
Public propertyIndex
Index of this object in HiddenLineDrawing.Points.
Public propertyLocation
Returns the location of this object in HiddenLineDrawing coordinates.
Public propertyPointVisibility
Returns the point's visibility
Public propertySourceObject
Return the source object that this point came from.
Public propertySourceObjectComponentIndex
Component of source object part that generated this curve.
Top
Methods
  NameDescription
Top
See Also