Click or drag to resize

Vector2f Structure

Represents the two components of a vector in two-dimensional space, using Single-precision floating point numbers.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Vector2f : IEquatable<Vector2f>, 
	IComparable<Vector2f>, IComparable, IEpsilonFComparable<Vector2f>, 
	IFormattable

The Vector2f type exposes the following members.

Constructors
  NameDescription
Public methodVector2f
Creates an instance.
Top
Properties
  NameDescription
Public propertyIsUnitVector
Gets a value indicating whether or not this is a unit vector. A unit vector has length 1.
Public propertyIsValid
Returns an indication regarding the validity of this vector.
Public propertyIsZero
Gets a value indicating whether the X, Y, and Z values are all equal to 0.0.
Public propertyLength
Computes the length (or magnitude, or size) of this vector. This is an application of Pythagoras' theorem. If this vector is invalid, its length is considered 0.
Public propertySquareLength
Returns the square of the length of this vector. This method does not check for the validity of its inputs.
Public propertyStatic memberUnset
Gets the value of the vector with each component set to RhinoMath.UnsetValue.
Public propertyX
Gets or sets the X (first) component of this vector.
Public propertyStatic memberXAxis
Gets the value of the vector with components 1,0.
Public propertyY
Gets or sets the Y (second) component of this vector.
Public propertyStatic memberYAxis
Gets the value of the vector with components 0,1.
Public propertyStatic memberZero
Gets the value of the vector with components 0,0.
Top
Methods
  NameDescription
Public methodStatic memberAdd(Point2f, Vector2f)
Sums up a point and a vector, and returns a new point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Vector2f, Vector2f)
Sums up two vectors.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodCompareTo
Compares this Vector2f with another Vector2f.

Components evaluation priority is first X, then Y.

Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified System.Object is a Vector2f and has the same values as the present vector.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Vector2f)
Determines whether the specified vector has the same values as the present vector.
Public methodGetHashCode
Computes a hash number that represents the current vector.
(Overrides ValueTypeGetHashCode.)
Public methodStatic memberMultiply
Multiplies two Vector2f together, returning the dot (internal) product of the two.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberNegate
Computes the reversed vector.

(Provided for languages that do not support operator overloading. You can use the - unary operator otherwise)

Public methodPerpendicularTo
Sets this vector to be perpendicular to another vector. Result is not unitized.
Public methodReverse
Reverses this vector in place (reverses the direction).

If this vector contains RhinoMath.UnsetValue, the reverse will also be invalid and false will be returned.

Public methodStatic memberSubtract
Subtracts the second vector from the first one.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Constructs the string representation of the current vector.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodUnitize
Unitizes the vector in place. A unit vector has length 1 unit.

An invalid or zero length vector cannot be unitized.

Top
Operators
  NameDescription
Public operatorStatic memberAddition(Point2f, Vector2f)
Sums up a point and a vector, and returns a new point.
Public operatorStatic memberAddition(Vector2f, Vector2f)
Computes the sum between two vectors.
Public operatorStatic memberEquality
Determines whether two vectors have equal values.
Public operatorStatic memberGreaterThan
Determines whether the first specified vector comes after (has superior sorting value than) the second vector.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified vector comes after (has superior sorting value than) the second vector, or it is equal to it.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberInequality
Determines whether two vectors have different values.
Public operatorStatic memberLessThan
Determines whether the first specified vector comes before (has inferior sorting value than) the second vector.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified vector comes before (has inferior sorting value than) the second vector, or it is equal to it.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberMultiply
Multiplies two Vector2f together, returning the dot (internal) product of the two.
Public operatorStatic memberSubtraction
Computes the difference between two vectors.
Public operatorStatic memberUnaryNegation
Computes the opposite vector.
Top
See Also