Click or drag to resize

Vector2fCompareTo Method

Compares this Vector2f with another Vector2f.

Components evaluation priority is first X, then Y.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int CompareTo(
	Vector2f other
)

Parameters

other
Type: Rhino.GeometryVector2f
The other Vector2f to use in comparison.

Return Value

Type: Int32

0: if this is identical to other

-1: if this.X < other.X

-1: if this.X == other.X and this.Y < other.Y

+1: otherwise.

Implements

IComparableTCompareTo(T)
See Also