Click or drag to resize

Vector2f Methods

The Vector2f type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAdd(Point2f, Vector2f)
Sums up a point and a vector, and returns a new point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Vector2f, Vector2f)
Sums up two vectors.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodCompareTo
Compares this Vector2f with another Vector2f.

Components evaluation priority is first X, then Y.

Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified System.Object is a Vector2f and has the same values as the present vector.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Vector2f)
Determines whether the specified vector has the same values as the present vector.
Public methodGetHashCode
Computes a hash number that represents the current vector.
(Overrides ValueTypeGetHashCode.)
Public methodStatic memberMultiply
Multiplies two Vector2f together, returning the dot (internal) product of the two.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberNegate
Computes the reversed vector.

(Provided for languages that do not support operator overloading. You can use the - unary operator otherwise)

Public methodPerpendicularTo
Sets this vector to be perpendicular to another vector. Result is not unitized.
Public methodReverse
Reverses this vector in place (reverses the direction).

If this vector contains RhinoMath.UnsetValue, the reverse will also be invalid and false will be returned.

Public methodStatic memberSubtract
Subtracts the second vector from the first one.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Constructs the string representation of the current vector.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodUnitize
Unitizes the vector in place. A unit vector has length 1 unit.

An invalid or zero length vector cannot be unitized.

Top
See Also