Click or drag to resize

Vector2f Operators

The Vector2f type exposes the following members.

Operators
  NameDescription
Public operatorStatic memberAddition(Point2f, Vector2f)
Sums up a point and a vector, and returns a new point.
Public operatorStatic memberAddition(Vector2f, Vector2f)
Computes the sum between two vectors.
Public operatorStatic memberEquality
Determines whether two vectors have equal values.
Public operatorStatic memberGreaterThan
Determines whether the first specified vector comes after (has superior sorting value than) the second vector.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified vector comes after (has superior sorting value than) the second vector, or it is equal to it.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberInequality
Determines whether two vectors have different values.
Public operatorStatic memberLessThan
Determines whether the first specified vector comes before (has inferior sorting value than) the second vector.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified vector comes before (has inferior sorting value than) the second vector, or it is equal to it.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberMultiply
Multiplies two Vector2f together, returning the dot (internal) product of the two.
Public operatorStatic memberSubtraction
Computes the difference between two vectors.
Public operatorStatic memberUnaryNegation
Computes the opposite vector.
Top
See Also