Click or drag to resize

ComponentIndex Structure

Represents an index of an element contained in another object.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct ComponentIndex : IEquatable<ComponentIndex>, 
	IComparable<ComponentIndex>

The ComponentIndex type exposes the following members.

Constructors
  NameDescription
Public methodComponentIndex
Construct component index with a specific type/index combination
Top
Properties
  NameDescription
Public propertyComponentIndexType
The interpretation of Index depends on the Type value. Type m_index interpretation (0 based indices) no_type used when context makes it clear what array is being index brep_vertex Brep.m_V[] array index brep_edge Brep.m_E[] array index brep_face Brep.m_F[] array index brep_trim Brep.m_T[] array index brep_loop Brep.m_L[] array index mesh_vertex Mesh.m_V[] array index meshtop_vertex MeshTopology.m_topv[] array index meshtop_edge MeshTopology.m_tope[] array index mesh_face Mesh.m_F[] array index idef_part InstanceDefinition.m_object_uuid[] array index polycurve_segment PolyCurve::m_segment[] array index dim_linear_point LinearDimension2::POINT_INDEX dim_radial_point RadialDimension2::POINT_INDEX dim_angular_point AngularDimension2::POINT_INDEX dim_ordinate_point OrdinateDimension2::POINT_INDEX dim_text_point TextEntity2 origin point.
Public propertyIndex
The interpretation of m_index depends on the m_type value. m_type m_index interpretation (0 based indices) no_type used when context makes it clear what array is being index brep_vertex Brep.m_V[] array index brep_edge Brep.m_E[] array index brep_face Brep.m_F[] array index brep_trim Brep.m_T[] array index brep_loop Brep.m_L[] array index mesh_vertex Mesh.m_V[] array index meshtop_vertex MeshTopology.m_topv[] array index meshtop_edge MeshTopology.m_tope[] array index mesh_face Mesh.m_F[] array index idef_part InstanceDefinition.m_object_uuid[] array index polycurve_segment PolyCurve::m_segment[] array index dim_linear_point LinearDimension2::POINT_INDEX dim_radial_point RadialDimension2::POINT_INDEX dim_angular_point AngularDimension2::POINT_INDEX dim_ordinate_point OrdinateDimension2::POINT_INDEX dim_text_point TextEntity2 origin point.
Public propertyStatic memberUnset
The unset value of component index.
Top
Methods
  NameDescription
Public methodCompareTo
Compares this ComponentIndex with another ComponentIndex.
Public methodEquals(ComponentIndex)
Determines whether the specified ComponentIndex is equal to the current ComponentIndex, comparing by value.
Public methodEquals(Object)
Determines whether the specified Object is equal to the current ComponentIndex, comparing by value.
(Overrides ValueTypeEquals(Object).)
Public methodGetHashCode
Computes the hash code for this ComponentIndex object.
(Overrides ValueTypeGetHashCode.)
Public methodIsUnset
Return true is this component index is the same as the Unset component index
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Determines whether two ComponentIndexes have equal values.
Public operatorStatic memberGreaterThan
Determines whether the first ComponentIndex comes after the second.
Public operatorStatic memberGreaterThanOrEqual
Determines whether the first ComponentIndex comes after the second, or it is equal to it.
Public operatorStatic memberInequality
Determines whether two ComponentIndexes have different values.
Public operatorStatic memberLessThan
Determines whether the first ComponentIndex comes before the second.
Public operatorStatic memberLessThanOrEqual
Determines whether the first ComponentIndex comes before the second, or it is equal to it.
Top
See Also