Click or drag to resize

ComponentIndexCompareTo Method

Compares this ComponentIndex with another ComponentIndex.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public int CompareTo(
	ComponentIndex other
)

Parameters

other
Type: Rhino.GeometryComponentIndex
The other ComponentIndex to use in comparison

Return Value

Type: Int32

0: if this is identical to other

-1: if this.ComponentIndexType < other.ComponentIndexType

-1: if this.ComponentIndexType == other.ComponentIndexType and this.Index < other.Index

+1: otherwise.

Implements

IComparableTCompareTo(T)
See Also