Click or drag to resize

Point3f Structure

Represents the three coordinates of a point in three-dimensional space, using Single-precision floating point numbers.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Point3f : IEquatable<Point3f>, 
	IComparable<Point3f>, IComparable, IEpsilonFComparable<Point3f>, 
	IFormattable

The Point3f type exposes the following members.

Constructors
  NameDescription
Public methodPoint3f
Initializes a new two-dimensional vector from two components.
Top
Properties
  NameDescription
Public propertyIsValid
Each coordinate of the point must pass the IsValidSingle(Single) test.
Public propertyStatic memberOrigin
Gets the value of a point at location 0,0,0.
Public propertyStatic memberUnset
Gets the value of a point at location RhinoMath.UnsetValue,RhinoMath.UnsetValue,RhinoMath.UnsetValue.
Public propertyX
Gets or sets the X (first) component of the vector.
Public propertyY
Gets or sets the Y (second) component of the vector.
Public propertyZ
Gets or sets the Z (third) component of the vector.
Top
Methods
  NameDescription
Public methodCompareTo
Compares this Point3f with another Point3f.

Component evaluation priority is first X, then Y, then Z.

Public methodCode exampleDistanceTo
Computes the distance between two points.
Public methodDistanceToSquared
Computes the squared distance between two points.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified System.Object is a Point3f and has the same values as the present point.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Point3f)
Determines whether the specified Point3f has the same values as the present point.
Public methodGetHashCode
Computes a hash code for the present point.
(Overrides ValueTypeGetHashCode.)
Public methodStatic memberSubtract
Subtracts a point from another point.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Constructs the string representation for the current point.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodTransform
Transforms the present point in place. The transformation matrix acts on the left of the point. i.e.,

result = transformation*point

Top
Operators
  NameDescription
Public operatorStatic memberAddition
Adds a point to another point.
Public operatorStatic memberEquality
Determines whether two points have equal values.
Public operatorStatic member(Point3d to Point3f)
Converts a double-precision point in a single-precision point. Needs explicit casting to help retain precision.
Public operatorStatic member(Point3f to Vector3f)
Converts a single-precision point in a single-precision vector. Needs explicit casting to help retain precision.
Public operatorStatic memberGreaterThan
Determines whether the first specified point comes after (has superior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified point comes after (has superior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberInequality
Determines whether two points have different values.
Public operatorStatic memberLessThan
Determines whether the first specified point comes before (has inferior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified point comes before (has inferior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberMultiply(Point3f, Single)
Multiplies a point by a factor.
Public operatorStatic memberMultiply(Single, Point3f)
Multiplies a point by a factor.
Public operatorStatic memberSubtraction
Subtracts a point from another point.
Top
See Also