Click or drag to resize

Point3f Operators and Type Conversions

The Point3f type exposes the following members.

Operators
  NameDescription
Public operatorStatic memberAddition
Adds a point to another point.
Public operatorStatic memberEquality
Determines whether two points have equal values.
Public operatorStatic member(Point3d to Point3f)
Converts a double-precision point in a single-precision point. Needs explicit casting to help retain precision.
Public operatorStatic member(Point3f to Vector3f)
Converts a single-precision point in a single-precision vector. Needs explicit casting to help retain precision.
Public operatorStatic memberGreaterThan
Determines whether the first specified point comes after (has superior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified point comes after (has superior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberInequality
Determines whether two points have different values.
Public operatorStatic memberLessThan
Determines whether the first specified point comes before (has inferior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified point comes before (has inferior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberMultiply(Point3f, Single)
Multiplies a point by a factor.
Public operatorStatic memberMultiply(Single, Point3f)
Multiplies a point by a factor.
Public operatorStatic memberSubtraction
Subtracts a point from another point.
Top
See Also