Click or drag to resize

Point3f Methods

The Point3f type exposes the following members.

Methods
  NameDescription
Public methodCompareTo
Compares this Point3f with another Point3f.

Component evaluation priority is first X, then Y, then Z.

Public methodCode exampleDistanceTo
Computes the distance between two points.
Public methodDistanceToSquared
Computes the squared distance between two points.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified System.Object is a Point3f and has the same values as the present point.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Point3f)
Determines whether the specified Point3f has the same values as the present point.
Public methodGetHashCode
Computes a hash code for the present point.
(Overrides ValueTypeGetHashCode.)
Public methodStatic memberSubtract
Subtracts a point from another point.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Constructs the string representation for the current point.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodTransform
Transforms the present point in place. The transformation matrix acts on the left of the point. i.e.,

result = transformation*point

Top
See Also