Click or drag to resize

Point3fCompareTo Method

Compares this Point3f with another Point3f.

Component evaluation priority is first X, then Y, then Z.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int CompareTo(
	Point3f other
)

Parameters

other
Type: Rhino.GeometryPoint3f
The other Point3d to use in comparison.

Return Value

Type: Int32

0: if this is identical to other

-1: if this.X < other.X

-1: if this.X == other.X and this.Y < other.Y

-1: if this.X == other.X and this.Y == other.Y and this.Z < other.Z

+1: otherwise.

Implements

IComparableTCompareTo(T)
See Also