Click or drag to resize

SubDEdge Class

Single edge of a SubD
Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class SubDEdge : SubDComponent

The SubDEdge type exposes the following members.

Properties
  NameDescription
Public propertyControlNetLine
Line representing the control net end points
Public propertyFaceCount
Number of faces for this edge
Public propertyTag
identifies the type of subdivision edge
Public propertyVertexFrom
Start vertex for this edge
Public propertyVertexTo
End vertex for this edge
Top
Methods
  NameDescription
Public methodFaceAt
Retrieve a SubDFace from this edge
Public methodToNurbsCurve
Get a cubic, uniform, non-rational, NURBS curve that is on the edge's limit curve.
Top
See Also