Click or drag to resize

SubDComponent Class

A part of SubD geometry. Common base class for vertices, faces, and edges
Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class SubDComponent

The SubDComponent type exposes the following members.

Properties
  NameDescription
Public propertyId
Unique id within the parent SubD for this item
Public propertyIsDamaged
Returns true if the SubD component is damaged.
Public propertyIsDeleted
Returns true if the SubD component is deleted.
Public propertyIsHidden
Returns true if the SubD component is hidden.
Public propertyIsHighlighted
Returns true if the SubD component is highlighted.
Public propertyIsLocked
Returns true if the SubD component is locked.
Public propertyIsSelected
Returns true if the SubD component is selected.
Public propertyParentSubD
SubD that this component belongs to
Top
Methods
  NameDescription
Top
See Also