Click or drag to resize

SubDVertex Class

Single vertex of a SubD
Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class SubDVertex : SubDComponent

The SubDVertex type exposes the following members.

Properties
  NameDescription
Public propertyControlNetPoint
Location of the "control net" point that this SubDVertex represents
Public propertyEdgeCount
Number of edges for this vertex
Public propertyEdges
All edges that this vertex is part of
Public propertyFaceCount
Number of faces for this vertex
Public propertyNext
Next vertex in linked list of vertices on this level
Public propertyPrevious
Previous vertex in linked list of vertices on this level
Public propertyTag
identifies the type of subdivision vertex
Top
Methods
  NameDescription
Public methodEdgeAt
Retrieve a SubDEdge from this vertex
Public methodFaceAt
Retrieve a SubDFace from this vertex
Public methodSetControlNetPoint
Change the location of the "control net" point that this SubDVertex represents
Public methodSurfacePoint
The SubD surface point
Top
See Also