Click or drag to resize

SubDFace Class

Single face of a SubD
Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class SubDFace : SubDComponent

The SubDFace type exposes the following members.

Properties
  NameDescription
Public propertyControlNetCenterFrame
The face's control net center frame is a plane with normal equal to ControlNetCenterNormal and origin equal to ControlNetCenterPoint. The x and y axes of the frame have no predictable relationship to the face or SubD control net topology.
Public propertyControlNetCenterNormal
When the face's control net polygon is planar, the face's control net normal is a unit vector perpendicular to the plane that points outwards. If the control net polygon is not planar, the control net normal is control net normal is a unit vector that is the average of the control polygon's corner normals.
Public propertyControlNetCenterPoint
The face's control net center point is the average of the face's vertex control net points. This is the same point as the face's subdivision point.
Public propertyEdgeCount
Number of edges for this face. Note that EdgeCount is always the same as VertexCount. Two properties are provided simply for clarity.
Public propertyLimitSurfaceCenterPoint
Get the limit surface point location at the center of the face
Public propertyPerFaceColor
If per-face color is "Empty", then this face does not have a custom color
Public propertySurfaceCenterFrame
Get the limit surface tangent plane at the center of the face. The plane's origin is the point on the limit surface at the center of the face. The plane's z axis is the limit surface normal vector at the center of the face.
Public propertySurfaceCenterNormal
Get the limit surface normal vector at the center of the face.
Public propertyVertexCount
Number of vertices for this face. Note that EdgeCount is always the same as VertexCount. Two properties are provided simply for clarity.
Top
Methods
  NameDescription
Public methodComponentIndex
Gets the component index of this face.
Public methodEdgeAt
Get an edge at a given index
Public methodEdgeDirectionMatchesFaceOrientation
Check if a given edge in this face has the same direction as the face orientation
Public methodVertexAt
Get a vertex that this face uses by index
Top
See Also