Click or drag to resize

MeshUnsafeLock Class

Permits access to the underlying mesh raw data structures in an unsafe way.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryMeshUnsafeLock

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class MeshUnsafeLock : IDisposable

The MeshUnsafeLock type exposes the following members.

Methods
  NameDescription
Public methodFaceNormalsArray
Retrieves a pointer to the raw mesh face normals array, which uses vectors defined with single precision floating point numbers, or throws an exception if none is available.
Public methodFacesArray
Retrieves a pointer to the raw faces array, which uses 4 integers for each face. MeshFace.
Public methodNormalVector3fArray
Retrieves a pointer to the raw mesh vertex normal array, which uses vectors defined with single precision floating point numbers, or throws an exception if none is available.
Public methodRelease
Releases the lock and updates the underlying unmanaged data structures.
Public methodVertexColorsArray
Retrieves a pointer to the raw mesh vertex colors array, which uses RGBA integers or throws an exception if none is available.
Public methodVertexPoint3dArray
Retrieves a pointer to the raw mesh vertex array, which uses coordinates defined with double precision floating point numbers, or throws an exception if none is available.
Public methodVertexPoint3fArray
Retrieves a pointer to the raw mesh vertex array, which uses coordinates defined with single precision floating point numbers, or null if none is available.
Top
Remarks
This lock object needs to be disposed before using the Mesh in other calculations and this can be achieved with the using keyword (Using in VB.Net).
See Also