Click or drag to resize

MeshUnsafeLock Methods

The MeshUnsafeLock type exposes the following members.

Methods
  NameDescription
Public methodFaceNormalsArray
Retrieves a pointer to the raw mesh face normals array, which uses vectors defined with single precision floating point numbers, or throws an exception if none is available.
Public methodFacesArray
Retrieves a pointer to the raw faces array, which uses 4 integers for each face. MeshFace.
Public methodNormalVector3fArray
Retrieves a pointer to the raw mesh vertex normal array, which uses vectors defined with single precision floating point numbers, or throws an exception if none is available.
Public methodRelease
Releases the lock and updates the underlying unmanaged data structures.
Public methodVertexColorsArray
Retrieves a pointer to the raw mesh vertex colors array, which uses RGBA integers or throws an exception if none is available.
Public methodVertexPoint3dArray
Retrieves a pointer to the raw mesh vertex array, which uses coordinates defined with double precision floating point numbers, or throws an exception if none is available.
Public methodVertexPoint3fArray
Retrieves a pointer to the raw mesh vertex array, which uses coordinates defined with single precision floating point numbers, or null if none is available.
Top
See Also