Click or drag to resize

BoundingBox Structure

Represents the value of two points in a bounding box defined by the two extreme corner points.

This box is therefore aligned to the world X, Y and Z axes.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct BoundingBox : ICloneable

The BoundingBox type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyArea
Gets the area of this BoundingBox.
Public propertyCenter
Gets the point in the center of the bounding box.
Public propertyDiagonal
Gets the diagonal vector of this BoundingBox. The diagonal connects the Min and Max points.
Public propertyStatic memberEmpty
Gets an [Empty] bounding box. An Empty box is an invalid structure that has negative width.
Public propertyIsValid
Gets a value that indicates whether or not this bounding box is valid. Empty boxes are not valid, and neither are boxes with unset points.
Public propertyMax
Gets or sets the point in the maximal corner.
Public propertyMin
Gets or sets the point in the minimal corner.
Public propertyStatic memberUnset
Gets a bounding box that has Unset coordinates for Min and Max.
Public propertyVolume
Gets the volume of this BoundingBox.
Top
Methods
  NameDescription
Public methodClosestPoint(Point3d)
Finds the closest point on or in the bounding box.
Public methodClosestPoint(Point3d, Boolean)
Finds the closest point on or in the bounding box.
Public methodContains(BoundingBox)
Determines whether this bounding box contains another bounding box.

This is the same as calling Contains(box,false).

Public methodContains(Point3d)
Tests a point for bounding box inclusion. This is the same as calling Contains(point, false)
Public methodContains(BoundingBox, Boolean)
Determines whether this bounding box contains another bounding box.

The user can choose how to treat bounding boxes with coincident surfaces.

Public methodContains(Point3d, Boolean)
Tests a point for BoundingBox inclusion.
Public methodCorner
Gets one of the eight corners of the box.
Public methodFurthestPoint
Finds the furthest point on the Box.
Public methodCode exampleGetCorners
Gets an array filled with the 8 corner points of this box.

See remarks for the return order.

Public methodGetEdges
Gets an array of the 12 edges of this box.
Public methodInflate(Double)
Inflates the box with equal amounts in all directions. Inflating with negative amounts may result in decreasing boxes.

Invalid boxes can not be inflated.

Public methodInflate(Double, Double, Double)
Inflate the box with custom amounts in all directions. Inflating with negative amounts may result in decreasing boxes.

InValid boxes can not be inflated.

Public methodStatic memberIntersection
Computes the intersection of two bounding boxes.
Public methodCode exampleIsDegenerate
Determines whether a bounding box is degenerate (flat) in one or more directions.
Public methodMakeValid
Ensures that the box is defined in an increasing fashion along X, Y and Z axes. If the Min or Max points are unset, this function will not change the box.
Public methodPointAt
Evaluates the bounding box with normalized parameters.

The box has idealized side length of 1x1x1.

Public methodCode exampleToBrep
Constructs a Brep representation of this bounding box.
Public methodToString
Constructs the string representation of this aligned bounding box.
(Overrides ValueTypeToString.)
Public methodTransform
Updates this bounding box to be the smallest axis aligned bounding box that contains the transformed result of its 8 original corner points.
Public methodUnion(BoundingBox)
Updates this BoundingBox to represent the union of itself and another box.
Public methodUnion(Point3d)
Updates this BoundingBox to represent the union of itself and a point.
Public methodStatic memberUnion(BoundingBox, BoundingBox)
Returns a new BoundingBox that represents the union of boxes a and b.
Public methodStatic memberUnion(BoundingBox, Point3d)
Returns a new BoundingBox that represents the union of a bounding box and a point.
Top
See Also