BoundingBox Methods |
The BoundingBox type exposes the following members.
Name | Description | |
---|---|---|
ClosestPoint(Point3d) |
Finds the closest point on or in the bounding box.
| |
ClosestPoint(Point3d, Boolean) |
Finds the closest point on or in the bounding box.
| |
Contains(BoundingBox) |
Determines whether this bounding box contains another bounding box.
This is the same as calling Contains(box,false). | |
Contains(Point3d) |
Tests a point for bounding box inclusion. This is the same as calling Contains(point, false)
| |
Contains(BoundingBox, Boolean) |
Determines whether this bounding box contains another bounding box.
The user can choose how to treat bounding boxes with coincident surfaces. | |
Contains(Point3d, Boolean) |
Tests a point for BoundingBox inclusion.
| |
Corner |
Gets one of the eight corners of the box.
| |
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.) | |
FurthestPoint |
Finds the furthest point on the Box.
| |
GetCorners |
Gets an array filled with the 8 corner points of this box.
See remarks for the return order. | |
GetEdges |
Gets an array of the 12 edges of this box.
| |
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
Inflate(Double) |
Inflates the box with equal amounts in all directions.
Inflating with negative amounts may result in decreasing boxes.
Invalid boxes can not be inflated. | |
Inflate(Double, Double, Double) |
Inflate the box with custom amounts in all directions.
Inflating with negative amounts may result in decreasing boxes.
InValid boxes can not be inflated. | |
Intersection |
Computes the intersection of two bounding boxes.
| |
IsDegenerate |
Determines whether a bounding box is degenerate (flat) in one or more directions.
| |
MakeValid |
Ensures that the box is defined in an increasing fashion along X, Y and Z axes.
If the Min or Max points are unset, this function will not change the box.
| |
PointAt |
Evaluates the bounding box with normalized parameters.
The box has idealized side length of 1x1x1. | |
ToBrep |
Constructs a Brep representation of this bounding box.
| |
ToString |
Constructs the string representation of this aligned bounding box.
(Overrides ValueTypeToString.) | |
Transform |
Updates this bounding box to be the smallest axis aligned
bounding box that contains the transformed result of its 8 original corner
points.
| |
Union(BoundingBox) |
Updates this BoundingBox to represent the union of itself and another box.
| |
Union(Point3d) |
Updates this BoundingBox to represent the union of itself and a point.
| |
Union(BoundingBox, BoundingBox) |
Returns a new BoundingBox that represents the union of boxes a and b.
| |
Union(BoundingBox, Point3d) |
Returns a new BoundingBox that represents the union of a bounding box and a point.
|