Click or drag to resize

BoundingBoxInflate Method (Double, Double, Double)

Inflate the box with custom amounts in all directions. Inflating with negative amounts may result in decreasing boxes.

InValid boxes can not be inflated.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public void Inflate(
	double xAmount,
	double yAmount,
	double zAmount
)

Parameters

xAmount
Type: SystemDouble
Amount (in model units) to inflate this box in the x direction.
yAmount
Type: SystemDouble
Amount (in model units) to inflate this box in the y direction.
zAmount
Type: SystemDouble
Amount (in model units) to inflate this box in the z direction.
See Also