Click or drag to resize

BoundingBox Properties

The BoundingBox type exposes the following members.

Properties
  NameDescription
Public propertyArea
Gets the area of this BoundingBox.
Public propertyCenter
Gets the point in the center of the bounding box.
Public propertyDiagonal
Gets the diagonal vector of this BoundingBox. The diagonal connects the Min and Max points.
Public propertyStatic memberEmpty
Gets an [Empty] bounding box. An Empty box is an invalid structure that has negative width.
Public propertyIsValid
Gets a value that indicates whether or not this bounding box is valid. Empty boxes are not valid, and neither are boxes with unset points.
Public propertyMax
Gets or sets the point in the maximal corner.
Public propertyMin
Gets or sets the point in the minimal corner.
Public propertyStatic memberUnset
Gets a bounding box that has Unset coordinates for Min and Max.
Public propertyVolume
Gets the volume of this BoundingBox.
Top
See Also