Click or drag to resize

ControlPoint Structure

Represents control point geometry with three-dimensional position and weight.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct ControlPoint : IEpsilonComparable<ControlPoint>, 
	IEquatable<ControlPoint>

The ControlPoint type exposes the following members.

Constructors
  NameDescription
Public methodControlPoint(Point3d)
Constructs a new world 3-D, or Euclidean, control point. The 4-D representation of this is (x, y, z, 1.0).
Public methodControlPoint(Point4d)
Constructs a new homogeneous control point, where the 4-D representation is (x, y, z, w). The world 3-D, or Euclidean, representation is (x/w, y/w, z/w).
Public methodControlPoint(Point3d, Double)
Constructs a control point from a world 3-D, or Euclidean, location and a weight. The world 3-D, or Euclidean, representation is (x/w, y/w, z/w).
Public methodControlPoint(Double, Double, Double)
Constructs a new world 3-D, or Euclidean, control point. The 4-D representation is (x, y, z, 1.0).
Public methodControlPoint(Double, Double, Double, Double)
Constructs a new homogeneous control point, where the 4-D representation is (x, y, z, w). The world 3-D, or Euclidean, representation is (x/w, y/w, z/w).
Top
Properties
  NameDescription
Public propertyLocation
Gets or sets world 3-D, or Euclidean location of the control point.
Public propertyStatic memberUnset
Gets the predefined, unset control point.
Public propertyWeight
Gets or sets the weight of this control point.
Public propertyX
Gets or sets the X coordinate of the control point.
Public propertyY
Gets or sets the Y coordinate of the control point.
Public propertyZ
Gets or sets the Z coordinate of the control point.
Top
Methods
  NameDescription
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(ControlPoint)
Determines if two points exactly match.
Top
See Also