Click or drag to resize

SubDEndCapStyle Enumeration

ON_SubDEndCapStyle enumerates the type of end caps functions like ON_SubD::CreateCylinder will create. Use ON_SubDEndCapStyleFromUnsigned(integer value) to convert integer values to an ON_SubDEndCapStyle. Use ON_SubDEndCapStyleToString(end_cap_style) to convert ON_SubDEndCapStyle values to string descriptions.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum SubDEndCapStyle
Members
  Member nameValueDescription
Unset0 Used to indicate the end cap style is not set.
None1 Ends are not capped.
Triangles2 Ends are capped with triangles.
Quads3 When the end has an even number of edges, is will be capped with quads. Otherwise it will be capped with triangles.
Ngon4 Ends are capped with a n-gon. This is a poor choice when there are a large number of edges in the end boundary.
See Also