Click or drag to resize

MeshExtruder Class

Extrudes a mesh and provides preview
Inheritance Hierarchy
SystemObject
  Rhino.GeometryMeshExtruder

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshExtruder : IDisposable

The MeshExtruder type exposes the following members.

Constructors
  NameDescription
Public methodMeshExtruder
Construct object to extrude given mesh faces, edges and ngons.
Top
Properties
  NameDescription
Public propertyEdgeBasedUVN
Edge based UVN defines UVN directions according to boundary edge directions
Public propertyFaceDirectionMode
Face direction mode determines how faces are oriented
Public propertyKeepOriginalFaces
Whether or not to keep original faces.
Public propertyPreviewLines
Gets Line objects to preview extruded mesh.
Public propertySurfaceParameterMode
Mode for creating surface parameters for extruded areas
Public propertyTextureCoordinateMode
Mode for creating texture coordinates for extruded areas
Public propertyTransform
Transform of extrusion
Public propertyUVN
Whether or not to perform extrude in UVN basis.
Top
Methods
  NameDescription
Public methodDispose
Dispose of this object and any unmanaged memory associated with it.
Public methodExtrudedMesh(Mesh)
Creates new extruded mesh. Returns true if any edges or faces were extruded.
Public methodExtrudedMesh(Mesh, ListComponentIndex)
Creates new extruded mesh. Returns true if any edges or faces were extruded.
Protected methodFinalize
Destructor
(Overrides ObjectFinalize.)
Public methodGetWallFaces
Return list of faces that were added to connect transformed edges/faces to non-transformed edges/faces.
Top
See Also