Click or drag to resize

MeshBooleanOptions Class

Contains a set of data to pass to boolean options.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryMeshBooleanOptions

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshBooleanOptions

The MeshBooleanOptions type exposes the following members.

Constructors
  NameDescription
Public methodMeshBooleanOptions
Initializes a new instance of the MeshBooleanOptions class
Top
Properties
  NameDescription
Public propertyCancellationToken
A token that allows to request the cancellation of the operation.
Public propertyProgressReporter
Gets or sets the object that is responsible to keep track of calculation progression.
Public propertyTextLog
Gets or sets a text log to write computed operations into.
Public propertyTolerance
Gets or sets a tolerance value for intersections and overlaps.
Top
Methods
  NameDescription
Top
See Also