BlendContinuity Enumeration |
Used in curve and surface blending and matching functions.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public enum BlendContinuity
Public Enumeration BlendContinuity
Members
| Member name | Value | Description |
---|
| Position | 0 |
G0: The curves or surfaces touch at the join point (position).
|
| Tangency | 1 |
G1: The curves or surfaces also share a common tangent direction at the join point (tangent).
|
| Curvature | 2 |
G2: The curves or surfaces also share a common center of curvature at the join point (curvature).
|
See Also