Click or drag to resize

ComponentStatus Structure

Provides information about selection, highlighting, visibility, editability and integrity states of a component.

This structure is immutable.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public struct ComponentStatus : IEquatable<ComponentStatus>

The ComponentStatus type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAllSet
All flags are checked.
Public propertyStatic memberClear
This is the default value and equal to undefined.
Public propertyStatic memberDamaged
The damaged flag is checked.
Public propertyStatic memberHidden
The hidden flag is checked.
Public propertyStatic memberHighlighted
The highlight selection flag is checked.
Public propertyIsClear
True if every setting is 0 or false.
Public propertyIsDamaged
Returns false if component is not damaged. True otherwise.
Public propertyIsHidden
Returns true if hidden. False otherwise.
Public propertyIsHighlighted
Returns true if highlighted. False otherwise.
Public propertyIsLocked
Returns true if locked. False otherwise.
Public propertyIsSelected
Returns true if selected or selected persistent. False otherwise.
Public propertyIsSelectedPersistent
Returns true if selected persistent. False otherwise.
Public propertyStatic memberLocked
The locked flag is checked.
Public propertyStatic memberSelected
The selection flag is checked.
Public propertyStatic memberSelectedPersistent
The persistent selection flag is checked.
Top
Methods
  NameDescription
Public methodEquals(ComponentStatus)
Determines if another ComponentStatus and this are equal.
Public methodEquals(Object)
Determines if an object and this are equal.
(Overrides ValueTypeEquals(Object).)
Public methodGetHashCode
Serves as a special hash function. The inner value is used for the purpose.
(Overrides ValueTypeGetHashCode.)
Public methodHasAllEqualStates
For the purposes of this test, Selected and SelectedPersistent are considered equal.
Public methodHasNoEqualStates
For the purposes of this test, Selected and SelectedPersistent are considered equal.
Public methodHasSomeEqualStates
For the purposes of this test, Selected and SelectedPersistent are considered equal.
Public methodToString
Provides a string representation of this ComponentStatus.
(Overrides ValueTypeToString.)
Public methodWithStates
Activates any information flag described in any of the two input component statuses and returns a new ComponentStatus with those flags checked.
Top
Operators
  NameDescription
Public operatorStatic memberAddition
Sets flags from both component states and returns a new ComponentStatus.
Public operatorStatic memberEquality
Determines if two ComponentStatus objects are equal.
Public operatorStatic memberInequality
Determines if two ComponentStatus objects differ.
Top
See Also