Click or drag to resize

ComponentStatus Properties

The ComponentStatus type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAllSet
All flags are checked.
Public propertyStatic memberClear
This is the default value and equal to undefined.
Public propertyStatic memberDamaged
The damaged flag is checked.
Public propertyStatic memberHidden
The hidden flag is checked.
Public propertyStatic memberHighlighted
The highlight selection flag is checked.
Public propertyIsClear
True if every setting is 0 or false.
Public propertyIsDamaged
Returns false if component is not damaged. True otherwise.
Public propertyIsHidden
Returns true if hidden. False otherwise.
Public propertyIsHighlighted
Returns true if highlighted. False otherwise.
Public propertyIsLocked
Returns true if locked. False otherwise.
Public propertyIsSelected
Returns true if selected or selected persistent. False otherwise.
Public propertyIsSelectedPersistent
Returns true if selected persistent. False otherwise.
Public propertyStatic memberLocked
The locked flag is checked.
Public propertyStatic memberSelected
The selection flag is checked.
Public propertyStatic memberSelectedPersistent
The persistent selection flag is checked.
Top
See Also