Click or drag to resize

ComponentStatus Methods

The ComponentStatus type exposes the following members.

Methods
  NameDescription
Public methodEquals(ComponentStatus)
Determines if another ComponentStatus and this are equal.
Public methodEquals(Object)
Determines if an object and this are equal.
(Overrides ValueTypeEquals(Object).)
Public methodGetHashCode
Serves as a special hash function. The inner value is used for the purpose.
(Overrides ValueTypeGetHashCode.)
Public methodHasAllEqualStates
For the purposes of this test, Selected and SelectedPersistent are considered equal.
Public methodHasNoEqualStates
For the purposes of this test, Selected and SelectedPersistent are considered equal.
Public methodHasSomeEqualStates
For the purposes of this test, Selected and SelectedPersistent are considered equal.
Public methodToString
Provides a string representation of this ComponentStatus.
(Overrides ValueTypeToString.)
Public methodWithStates
Activates any information flag described in any of the two input component statuses and returns a new ComponentStatus with those flags checked.
Top
See Also