Click or drag to resize

IsoStatus Enumeration

Defines enumerated values for isoparametric curve direction on a surface, such as X or Y, and curve sides, such as North or West boundary.

Note: odd values are all x-constant; even values > 0 are all y-constant.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public enum IsoStatus
Members
  Member nameValueDescription
None0 curve is not an isoparametric curve.
X1 curve is a "x" = constant (vertical) isoparametric curve in the interior of the surface's domain.
Y2 curve is a "y" = constant (horizontal) isoparametric curve in the interior of the surface's domain.
West3 curve is a "x" = constant isoparametric curve along the west side of the surface's domain.
South4 curve is a "y" = constant isoparametric curve along the south side of the surface's domain.
East5 curve is a "x" = constant isoparametric curve along the east side of the surface's domain.
North6 curve is a "y" = constant isoparametric curve along the north side of the surface's domain.
See Also