Click or drag to resize

SurfaceCurvature Class

Maintains computed information for surface curvature evaluation.
Inheritance Hierarchy
SystemObject
  Rhino.GeometrySurfaceCurvature

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SurfaceCurvature

The SurfaceCurvature type exposes the following members.

Properties
  NameDescription
Public propertyCode exampleGaussian
Gets the Gaussian curvature value at UV.
Public propertyCode exampleMean
Gets the Mean curvature value at UV.
Public propertyCode exampleNormal
Gets the surface normal at UV.
Public propertyCode examplePoint
Gets the surface point at UV.
Public propertyUVPoint
Gets the UV location where the curvature was computed.
Top
Methods
  NameDescription
Public methodCode exampleDirection
Gets the principal curvature direction vector.
Public methodCode exampleKappa
Gets the principal curvature values. Kappa(0) - Principal curvature with maximum absolute value Kappa(1) - Principal curvature with minimum absolute value
Public methodOsculatingCircle
Computes the osculating circle along the given direction.
Top
See Also