Click or drag to resize

SubDToBrepOptions Class

Options used for converting a SubD to a Brep
Inheritance Hierarchy
SystemObject
  Rhino.GeometrySubDToBrepOptions

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SubDToBrepOptions : IDisposable

The SubDToBrepOptions type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyStatic memberDefault
Default SubDToBrepOptions settings. Currently selects the same options as DefaultUnpacked: Locally-G1 smoothing of extraordinary vertices, unpacked faces.
Public propertyStatic memberDefaultPacked
Default ON_SubDToBrepParameters settings for creating a packed brep. Locally-G1 smoothing of extraordinary vertices, packed faces.
Public propertyStatic memberDefaultUnpacked
Default ON_SubDToBrepParameters settings for creating an unpacked brep. Locally-G1 smoothing of extraordinary vertices, unpacked faces.
Public propertyExtraordinaryVertexProcess
Get or sets the extraordinary vertex process option.
Public propertyPackFaces
Get or sets the pack faces option.
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Top
See Also