Click or drag to resize

Rectangle3d Structure

Represents the values of a plane and two intervals that form an oriented rectangle in three dimensions.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Rectangle3d : IEpsilonComparable<Rectangle3d>, 
	ICloneable

The Rectangle3d type exposes the following members.

Constructors
  NameDescription
Public methodRectangle3d(Plane, Interval, Interval)
Initializes a new rectangle from dimensions.
Public methodRectangle3d(Plane, Point3d, Point3d)
Initializes a new rectangle from a base plane and two corner points.
Public methodRectangle3d(Plane, Double, Double)
Initializes a new rectangle from width and height.
Top
Properties
  NameDescription
Public propertyArea
Gets the unsigned Area of the rectangle.
Public propertyBoundingBox
Gets the world aligned bounding box for this rectangle.
Public propertyCenter
Gets the point in the center of the rectangle.
Public propertyCircumference
Gets the circumference of the rectangle.
Public propertyHeight
Gets the signed height of the rectangle. If the Y dimension is decreasing, the height will be negative.
Public propertyIsValid
Gets a value indicating whether or not this is a valid rectangle. A rectangle is considered to be valid when the base plane and both dimensions are valid.
Public propertyPlane
Gets or sets the base plane of the rectangle.
Public propertyStatic memberUnset
Gets a rectangle with Unset components.
Public propertyWidth
Gets the signed width of the rectangle. If the X dimension is decreasing, the width will be negative.
Public propertyX
Gets or sets the dimensions of the rectangle along the base plane X-Axis (i.e. the width).
Public propertyY
Gets or sets the dimensions of the rectangle along the base plane Y-Axis (i.e. the height).
Top
Methods
  NameDescription
Public methodClosestPoint(Point3d)
Gets the point on the rectangle that is closest to a test-point.
Public methodClosestPoint(Point3d, Boolean)
Gets the point on the rectangle that is closest to a test-point.
Public methodContains(Point3d)
Determines if a point is included in this rectangle.
Public methodContains(Double, Double)
Determines if two plane parameters are included in this rectangle.
Public methodCorner
Gets the corner at the given index.
Public methodStatic memberCreateFromPolyline(IEnumerablePoint3d)
Attempts to create a rectangle from a polyline. This method only works well for polylines that already closely resemble rectangles. If the polyline contains more than four vertices, the least significant ones will be ignored. If the polylines is non-orthogonal, the discrepancies will be averaged away. This method should not be used as a Rectangle fitter.
Public methodStatic memberCreateFromPolyline(IEnumerablePoint3d, Double, Double)
Attempts to create a rectangle from a polyline. This method only works well for polylines that already closely resemble rectangles. If the polyline contains more than four vertices, the least significant ones will be ignored. If the polylines is non-orthogonal, the discrepancies will be averaged away. This method should not be used as a Rectangle fitter.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodMakeIncreasing
Ensures the X and Y dimensions are increasing or singleton intervals.
Public methodPointAt(Double)
Gets a point along the rectangle boundary.
Public methodPointAt(Double, Double)
Gets a point in Rectangle space.
Public methodRecenterPlane(Int32)
Re-centers the base plane on one of the corners.
Public methodRecenterPlane(Point3d)
Re-centers the base plane on a new origin.
Public methodToNurbsCurve
Constructs a nurbs curve representation of this rectangle.
Public methodToPolyline
Constructs a polyline from this rectangle.
Public methodTransform
Transforms this rectangle. Note that rectangles cannot be skewed or tapered.
Top
See Also