Click or drag to resize

Rectangle3d Methods

The Rectangle3d type exposes the following members.

Methods
  NameDescription
Public methodClosestPoint(Point3d)
Gets the point on the rectangle that is closest to a test-point.
Public methodClosestPoint(Point3d, Boolean)
Gets the point on the rectangle that is closest to a test-point.
Public methodContains(Point3d)
Determines if a point is included in this rectangle.
Public methodContains(Double, Double)
Determines if two plane parameters are included in this rectangle.
Public methodCorner
Gets the corner at the given index.
Public methodStatic memberCreateFromPolyline(IEnumerablePoint3d)
Attempts to create a rectangle from a polyline. This method only works well for polylines that already closely resemble rectangles. If the polyline contains more than four vertices, the least significant ones will be ignored. If the polylines is non-orthogonal, the discrepancies will be averaged away. This method should not be used as a Rectangle fitter.
Public methodStatic memberCreateFromPolyline(IEnumerablePoint3d, Double, Double)
Attempts to create a rectangle from a polyline. This method only works well for polylines that already closely resemble rectangles. If the polyline contains more than four vertices, the least significant ones will be ignored. If the polylines is non-orthogonal, the discrepancies will be averaged away. This method should not be used as a Rectangle fitter.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodMakeIncreasing
Ensures the X and Y dimensions are increasing or singleton intervals.
Public methodPointAt(Double)
Gets a point along the rectangle boundary.
Public methodPointAt(Double, Double)
Gets a point in Rectangle space.
Public methodRecenterPlane(Int32)
Re-centers the base plane on one of the corners.
Public methodRecenterPlane(Point3d)
Re-centers the base plane on a new origin.
Public methodToNurbsCurve
Constructs a nurbs curve representation of this rectangle.
Public methodToPolyline
Constructs a polyline from this rectangle.
Public methodTransform
Transforms this rectangle. Note that rectangles cannot be skewed or tapered.
Top
See Also