Click or drag to resize

Rectangle3dClosestPoint Method (Point3d, Boolean)

Gets the point on the rectangle that is closest to a test-point.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Point3d ClosestPoint(
	Point3d point,
	bool includeInterior
)

Parameters

point
Type: Rhino.GeometryPoint3d
Point to project.
includeInterior
Type: SystemBoolean
If false, the point is projected onto the boundary edge only, otherwise the interior of the rectangle is also taken into consideration.

Return Value

Type: Point3d
The point on the rectangle closest to the test point or Point3d.Unset on failure.
See Also