Click or drag to resize

Rectangle3d Properties

The Rectangle3d type exposes the following members.

Properties
  NameDescription
Public propertyArea
Gets the unsigned Area of the rectangle.
Public propertyBoundingBox
Gets the world aligned bounding box for this rectangle.
Public propertyCenter
Gets the point in the center of the rectangle.
Public propertyCircumference
Gets the circumference of the rectangle.
Public propertyHeight
Gets the signed height of the rectangle. If the Y dimension is decreasing, the height will be negative.
Public propertyIsValid
Gets a value indicating whether or not this is a valid rectangle. A rectangle is considered to be valid when the base plane and both dimensions are valid.
Public propertyPlane
Gets or sets the base plane of the rectangle.
Public propertyStatic memberUnset
Gets a rectangle with Unset components.
Public propertyWidth
Gets the signed width of the rectangle. If the X dimension is decreasing, the width will be negative.
Public propertyX
Gets or sets the dimensions of the rectangle along the base plane X-Axis (i.e. the width).
Public propertyY
Gets or sets the dimensions of the rectangle along the base plane Y-Axis (i.e. the height).
Top
See Also